# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=attrs=\[\[[^\]]*(?:](?!])[^\]]*)*),(\s*)/],$1[/gm;t' <<< "this.mk(attrs=[[keyCollection.key: 40]]))
this.mk(attrs=[[keyCollection.key: 50, override.key: override.value]])
this.mk(attrs=[[keyCollection.key: 60,
override.key: override.value]])"