# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=attrs=\[\[[^\]]*(?:](?!])[^\]]*)*),(\s*)"
test_str = ("this.mk(attrs=[[keyCollection.key: 40]]))\n"
"this.mk(attrs=[[keyCollection.key: 50, override.key: override.value]])\n"
"this.mk(attrs=[[keyCollection.key: 60, \n"
" override.key: override.value]])")
subst = "],$1["
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.