use strict;
my $str = 'this.mk(attrs=[[keyCollection.key: 40]]))
this.mk(attrs=[[keyCollection.key: 50, override.key: override.value]])
this.mk(attrs=[[keyCollection.key: 60,
override.key: override.value]])';
my $regex = qr/(?<=attrs=\[\[[^\]]*(?:](?!])[^\]]*)*),(\s*)/mp;
my $subst = '],$1[';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";