import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?|(((8|\\+7)[\\- ]?)?(\\(?\\d{3}\\)?[\\- ]?)?[\\d\\- ]{7,10}|(38\\(026\\)123-45-67)|\\+380 123 45 67))$";
final String string = "+79261234567\n"
+ "89261234567\n"
+ "79261234 567\n"
+ "+380 123 45 67\n"
+ "38(026)123-45-67\n"
+ "9261234567\n"
+ "79261234567\n"
+ "(495)1234567\n"
+ "(495) 123 45 67\n"
+ "89261234567\n"
+ "8-926-123-45-67\n"
+ "8 927 1234 234\n"
+ "8 927 12 12 888\n"
+ "8 927 12 555 12\n"
+ "8 927 123 8 123\n\n\n"
+ "Пример с условием\n"
+ "/(?|(candy)|(kiss)|(berry))/g\n"
+ "A candy, kiss, or even a berry is delicious.\n"
+ "$1 =candykissberry ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}