const regex = /^(?|(((8|\+7)[\- ]?)?(\(?\d{3}\)?[\- ]?)?[\d\- ]{7,10}|(38\(026\)123-45-67)|\+380 123 45 67))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?|(((8|\\+7)[\\- ]?)?(\\(?\\d{3}\\)?[\\- ]?)?[\\d\\- ]{7,10}|(38\\(026\\)123-45-67)|\\+380 123 45 67))$', 'gm')
const str = `+79261234567
89261234567
79261234 567
+380 123 45 67
38(026)123-45-67
9261234567
79261234567
(495)1234567
(495) 123 45 67
89261234567
8-926-123-45-67
8 927 1234 234
8 927 12 12 888
8 927 12 555 12
8 927 123 8 123
Пример с условием
/(?|(candy)|(kiss)|(berry))/g
A candy, kiss, or even a berry is delicious.
\$1 =candykissberry `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}