#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((.*?)\){3}[\s]*,?"
Local $sString = "((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ," & @CRLF & _
"" & @CRLF & _
"((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")