re = /\((.*?)\){3}[\s]*,?/m
str = '((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,
((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end