// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((.*?)\){3}[\s]*,?").unwrap();
let string = "((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,
((Test_1, (3.7, 88, test,, str)), (Test_2, (1.9, 33, test,, str))) ,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}