using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^6(?!52[12])(?:011|5[0-9][0-9])[0-9]{12}$";
string input = @"6012345678901234
6521123456789012
6522123456789012
60123456789012341
65211234567890122
65221234567890123
6011221234567890
6522123456789012
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}