re = /^6(?!52[12])(?:011|5[0-9][0-9])[0-9]{12}$/m
str = '6012345678901234
6521123456789012
6522123456789012
60123456789012341
65211234567890122
65221234567890123
6011221234567890
6522123456789012
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end