const regex = /^6(?!52[12])(?:011|5[0-9][0-9])[0-9]{12}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^6(?!52[12])(?:011|5[0-9][0-9])[0-9]{12}$', 'gm')
const str = `6012345678901234
6521123456789012
6522123456789012
60123456789012341
65211234567890122
65221234567890123
6011221234567890
6522123456789012
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}