#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+[-\.\w]*@(?!(?:outlook|myemail|yahoo)\.com$)\w+[-\.\w]*?\.\w{2,4}$"
Local $sString = "asdf@hotmail.com" & @CRLF & _
"qwer@live.com" & @CRLF & _
"zxcv@gmail.com" & @CRLF & _
"jklj@hotmail.cl" & @CRLF & _
"gfdfsd@outlook.com" & @CRLF & _
"gfjdkh@yahoo.com" & @CRLF & _
"jioj@myemail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")