$re = '/^\w+[-\.\w]*@(?!(?:outlook|myemail|yahoo)\.com$)\w+[-\.\w]*?\.\w{2,4}$/m';
$str = 'asdf@hotmail.com
qwer@live.com
zxcv@gmail.com
jklj@hotmail.cl
gfdfsd@outlook.com
gfjdkh@yahoo.com
jioj@myemail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);