const regex = /^\w+[-\.\w]*@(?!(?:outlook|myemail|yahoo)\.com$)\w+[-\.\w]*?\.\w{2,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+[-\\.\\w]*@(?!(?:outlook|myemail|yahoo)\\.com$)\\w+[-\\.\\w]*?\\.\\w{2,4}$', 'gm')
const str = `asdf@hotmail.com
qwer@live.com
zxcv@gmail.com
jklj@hotmail.cl
gfdfsd@outlook.com
gfjdkh@yahoo.com
jioj@myemail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}