import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?\\d{0,2}?[\\s.-]?\\(?\\d{3}\\)?[\\s.-]?\\d{3}[\\s.-]?\\d{4}";
final String string = "951-719-9170ZoeWellish@superrito.com\n"
+ "PamelaSHill@cuvox.de+1 (217) 569-3204\n"
+ "402-363-6804JaeMDebord@gustr.com\n"
+ "PhanBaLiem@jourrapide.com+1 (732) 636-8246\n"
+ "334-515-7487TimNeudorf@cuvox.de\n"
+ "386-334-5237RafaelCardosoCosta@gustr.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}