use strict;
my $str = '951-719-9170ZoeWellish@superrito.com
PamelaSHill@cuvox.de+1 (217) 569-3204
402-363-6804JaeMDebord@gustr.com
PhanBaLiem@jourrapide.com+1 (732) 636-8246
334-515-7487TimNeudorf@cuvox.de
386-334-5237RafaelCardosoCosta@gustr.com';
my $regex = qr/\+?\d{0,2}?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}