import re
regex = re.compile(r"\+?\d{0,2}?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}", flags=re.MULTILINE)
test_str = ("951-719-9170ZoeWellish@superrito.com\n"
"PamelaSHill@cuvox.de+1 (217) 569-3204\n"
"402-363-6804JaeMDebord@gustr.com\n"
"PhanBaLiem@jourrapide.com+1 (732) 636-8246\n"
"334-515-7487TimNeudorf@cuvox.de\n"
"386-334-5237RafaelCardosoCosta@gustr.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")