using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(=)\{(\S*)(\}&?|\}$)";
string input = @"queryA={valueA1{{valueA1a}}&valueA2{{valueA2a}}}&queryB={valueB1{{valueB1a}}&valueB2{{valueB2a}}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}