re = /(=)\{(\S*)(\}&?|\}$)/
str = 'queryA={valueA1{{valueA1a}}&valueA2{{valueA2a}}}&queryB={valueB1{{valueB1a}}&valueB2{{valueB2a}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end