package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(=)\{(\S*)(\}&?|\}$)`)
var str = `queryA={valueA1{{valueA1a}}&valueA2{{valueA2a}}}&queryB={valueB1{{valueB1a}}&valueB2{{valueB2a}}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}