using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(13|24|28)\d{6}$)|(^\d{2}(55|99)\d{4}$)|(^\d{4}(20|21)\d{2}$)|(^\d{6}(42|38|09|17|66)$)";
string input = @"12345678
13345678
12555678
12342078
12345666";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}