$re = '/(^(13|24|28)\d{6}$)|(^\d{2}(55|99)\d{4}$)|(^\d{4}(20|21)\d{2}$)|(^\d{6}(42|38|09|17|66)$)/m';
$str = '12345678
13345678
12555678
12342078
12345666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);