const regex = /(^(13|24|28)\d{6}$)|(^\d{2}(55|99)\d{4}$)|(^\d{4}(20|21)\d{2}$)|(^\d{6}(42|38|09|17|66)$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(13|24|28)\\d{6}$)|(^\\d{2}(55|99)\\d{4}$)|(^\\d{4}(20|21)\\d{2}$)|(^\\d{6}(42|38|09|17|66)$)', 'gm')
const str = `12345678
13345678
12555678
12342078
12345666`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}