import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{4}-\\d{4}-\\d{2}|\\d{5}-(?:\\d{3}-\\d{2}|\\d{4}-\\d{1,2})|\\d{11}|\\d{10}|\\d{9})$";
final String string = "1234-1234-12\n"
+ "12345-123-12\n"
+ "12345-1234-1\n"
+ "12345-1234-12\n"
+ "12345678902\n"
+ "1234567890\n"
+ "123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}