import re
regex = re.compile(r"^(?:\d{4}-\d{4}-\d{2}|\d{5}-(?:\d{3}-\d{2}|\d{4}-\d{1,2})|\d{11}|\d{10}|\d{9})$", flags=re.MULTILINE)
test_str = ("1234-1234-12\n"
"12345-123-12\n"
"12345-1234-1\n"
"12345-1234-12\n"
"12345678902\n"
"1234567890\n"
"123456789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")