re = /^(?:\d{4}-\d{4}-\d{2}|\d{5}-(?:\d{3}-\d{2}|\d{4}-\d{1,2})|\d{11}|\d{10}|\d{9})$/m
str = '1234-1234-12
12345-123-12
12345-1234-1
12345-1234-12
12345678902
1234567890
123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end