#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td>[A-Z0-9-]+<\/td>"
Local $sString = "<table class="stripeMe">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <th>Image</th>" & @CRLF & _
" <th>Part#</th>" & @CRLF & _
" <th>Original#</th>" & @CRLF & _
" <th>Description</th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="alt">" & @CRLF & _
" <td>" & @CRLF & _
" <a href="/item/8438657/High_Capacity/AC-C27/18_TO_20_VOLT_65_WATT_AC_ADAPT"><img width="75" height="75" title="AM11X-2719 18 TO 20 Volt 65 Watt AC Adapter" src="/shop/images/image.php?img=BAT\8438657.jpg&thumbnail=Y"></a>" & @CRLF & _
" </td>" & @CRLF & _
" <td><a title="AM11X-2719 18 TO 20 Volt 65 Watt AC Adapter" href="/item/8438657/High_Capacity/AC-C27/18_TO_20_VOLT_65_WATT_AC_ADAPT">AC-C27</a></td>" & @CRLF & _
" <td>TR82J</td>" & @CRLF & _
" <td>18 TO 20 Volt 65 Watt AC Adapter</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="">" & @CRLF & _
" <td>" & @CRLF & _
" <a href="/item/10242499/High_Capacity/DRAC90B/DURACELL_90W_19V_UNIVERSAL_NOT"><img width="75" height="75" title="AM11X-2719 Duracell 90W 19V Universal Notebook AC Adapter" src="/shop/images/no_picture_thumb.jpg"></a>" & @CRLF & _
" </td>" & @CRLF & _
" <td><a title="AM11X-2719 Duracell 90W 19V Universal Notebook AC Adapter" href="/item/10242499/High_Capacity/DRAC90B/DURACELL_90W_19V_UNIVERSAL_NOT">DRAC90B</a></td>" & @CRLF & _
" <td>331-0536</td>" & @CRLF & _
" <td>Duracell 90W 19V Universal Notebook AC Adapter</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")