import Foundation
let pattern = #"<td>[A-Z0-9-]+<\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<table class="stripeMe">
<tbody>
<tr>
<th>Image</th>
<th>Part#</th>
<th>Original#</th>
<th>Description</th>
</tr>
<tr class="alt">
<td>
<a href="/item/8438657/High_Capacity/AC-C27/18_TO_20_VOLT_65_WATT_AC_ADAPT"><img width="75" height="75" title="AM11X-2719 18 TO 20 Volt 65 Watt AC Adapter" src="/shop/images/image.php?img=BAT\8438657.jpg&thumbnail=Y"></a>
</td>
<td><a title="AM11X-2719 18 TO 20 Volt 65 Watt AC Adapter" href="/item/8438657/High_Capacity/AC-C27/18_TO_20_VOLT_65_WATT_AC_ADAPT">AC-C27</a></td>
<td>TR82J</td>
<td>18 TO 20 Volt 65 Watt AC Adapter</td>
</tr>
<tr class="">
<td>
<a href="/item/10242499/High_Capacity/DRAC90B/DURACELL_90W_19V_UNIVERSAL_NOT"><img width="75" height="75" title="AM11X-2719 Duracell 90W 19V Universal Notebook AC Adapter" src="/shop/images/no_picture_thumb.jpg"></a>
</td>
<td><a title="AM11X-2719 Duracell 90W 19V Universal Notebook AC Adapter" href="/item/10242499/High_Capacity/DRAC90B/DURACELL_90W_19V_UNIVERSAL_NOT">DRAC90B</a></td>
<td>331-0536</td>
<td>Duracell 90W 19V Universal Notebook AC Adapter</td>
</tr>
</tbody>
</table>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)