import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:CREATE(?:(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+OR(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+REPLACE)?|DROP)(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+TABLE(?:(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+IF(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+EXISTS)?|UPDATE|DELETE|INSERT(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+INTO)(?:\\s*\\/\\*.*\\*\\/\\s*?)*\\s+([^\\s\\/*]+)";
final String string = "CREATE TABLE tbl1 ...\n"
+ "CREATE OR REPLACE TABLE tbl1 ...\n"
+ "DROP TABLE IF EXISTS tbl1; CREATE TABLE tbl1 ...\n"
+ "INSERT /*some comment*/ INTO tbl2 ...\n"
+ "INSERT /*some comment*/ INTO tbl2 ...\n"
+ "UPDATE tbl3 SET col1 = ...\n"
+ "/*some garbage comments*/ UPDATE tbl3 SET col1 = ... \n"
+ "DELETE tbl4 ...\n"
+ "#1 some optional statements like drop table CREATE /*some comments*/ TABLE table_name everything else\n"
+ "#1 some optional statements like drop table CREATE /*some comments*/ OR REPLACE TABLE table_name everything else\n"
+ "#2 some optional statements like drop table INSERT /*some comments*/ INTO /*some comments*/ table_name\n"
+ "#3 some optional statements like drop table UPDATE /*some comments*/ table_name everything else";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}