use strict;
my $str = 'CREATE TABLE tbl1 ...
CREATE OR REPLACE TABLE tbl1 ...
DROP TABLE IF EXISTS tbl1; CREATE TABLE tbl1 ...
INSERT /*some comment*/ INTO tbl2 ...
INSERT /*some comment*/ INTO tbl2 ...
UPDATE tbl3 SET col1 = ...
/*some garbage comments*/ UPDATE tbl3 SET col1 = ...
DELETE tbl4 ...
#1 some optional statements like drop table CREATE /*some comments*/ TABLE table_name everything else
#1 some optional statements like drop table CREATE /*some comments*/ OR REPLACE TABLE table_name everything else
#2 some optional statements like drop table INSERT /*some comments*/ INTO /*some comments*/ table_name
#3 some optional statements like drop table UPDATE /*some comments*/ table_name everything else';
my $regex = qr/(?:(?:CREATE(?:(?:\s*\/\*.*\*\/\s*?)*\s+OR(?:\s*\/\*.*\*\/\s*?)*\s+REPLACE)?|DROP)(?:\s*\/\*.*\*\/\s*?)*\s+TABLE(?:(?:\s*\/\*.*\*\/\s*?)*\s+IF(?:\s*\/\*.*\*\/\s*?)*\s+EXISTS)?|UPDATE|DELETE|INSERT(?:\s*\/\*.*\*\/\s*?)*\s+INTO)(?:\s*\/\*.*\*\/\s*?)*\s+([^\s\/*]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}