const regex = /(?:(?:CREATE(?:(?:\s*\/\*.*\*\/\s*?)*\s+OR(?:\s*\/\*.*\*\/\s*?)*\s+REPLACE)?|DROP)(?:\s*\/\*.*\*\/\s*?)*\s+TABLE(?:(?:\s*\/\*.*\*\/\s*?)*\s+IF(?:\s*\/\*.*\*\/\s*?)*\s+EXISTS)?|UPDATE|DELETE|INSERT(?:\s*\/\*.*\*\/\s*?)*\s+INTO)(?:\s*\/\*.*\*\/\s*?)*\s+([^\s\/*]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:CREATE(?:(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+OR(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+REPLACE)?|DROP)(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+TABLE(?:(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+IF(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+EXISTS)?|UPDATE|DELETE|INSERT(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+INTO)(?:\\s*\\\/\\*.*\\*\\\/\\s*?)*\\s+([^\\s\\\/*]+)', 'gm')
const str = `CREATE TABLE tbl1 ...
CREATE OR REPLACE TABLE tbl1 ...
DROP TABLE IF EXISTS tbl1; CREATE TABLE tbl1 ...
INSERT /*some comment*/ INTO tbl2 ...
INSERT /*some comment*/ INTO tbl2 ...
UPDATE tbl3 SET col1 = ...
/*some garbage comments*/ UPDATE tbl3 SET col1 = ...
DELETE tbl4 ...
#1 some optional statements like drop table CREATE /*some comments*/ TABLE table_name everything else
#1 some optional statements like drop table CREATE /*some comments*/ OR REPLACE TABLE table_name everything else
#2 some optional statements like drop table INSERT /*some comments*/ INTO /*some comments*/ table_name
#3 some optional statements like drop table UPDATE /*some comments*/ table_name everything else`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}