import re
regex = re.compile(r"""
^\d+:\s+
(
((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*A(AB)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*A(AB)*A)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*B(BA)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*B(BA)*B)
)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("4: AAAA\n"
"3: AAA\n"
"2: AA\n"
"1: A\n"
"4: BBBB\n"
"3: BBB\n"
"2: BB\n"
"1: B\n"
"2: AABBBBAAAABBBBAAAABBBB\n"
"3: AAABBBBAAABBBBAAAABBB\n"
"5: AAAAABBBBAAAABBBBAAAABB\n"
"3: AABBBAAAABBBBAAAABBBBAAA\n"
"4: AAABBBAAAABBBBAAAABBBBAA\n"
"1: ABABABABABABABABABABABABABABAB\n"
"8: AAAAAABBBBAAAAABBBBAAAAABBBB\n"
"2: AABBBBAAAABBBBAAAABBBBAAAAB\n"
"4: AAAABBBAAABBBAAABBBAAABBB\n"
"8: ABBBAAAABBAAAABBAAAABBAAAABB\n"
"5: AAABBBBAAAABBBAAAABBBAAAABB\n"
"1: ABABABABABABABABABABABABABABABAB\n"
"10: AAAAAABBBBAAAAAABBBBAAAAAABBBB\n"
"2: AABBBBAAAABBBBAAAABBBBAAAABB\n"
"4: AAAABBBAAABBBAAABBBAAABBBAA\n"
"8: ABBBAAAABBAAAABBAAAABBAAAAB\n"
"5: AAABBBBAAAABBBAAAABBBAAAAB\n"
"1: ABABABABABABABABABABABABABABAB\n"
"10: AAAAAABBBBAAAAAABBBBAAAAAABBB\n"
"2: AABBBBAAAABBBBAAAABBBBAAAABB\n"
"4: AAAABBBAAABBBAAABBBAAABBBAAA\n"
"8: ABBBAAAABBAAAABBAAAABBAAAABB\n"
"5: AAABBBBAAAABBBAAAABBBAAAABB\n"
"1: ABABABABABABABABABABABABABABABABAB\n"
"10: AAAAAABBBBAAAAAABBBBAAAAAABBBB\n"
"2: AABBBBAAAABBBBAAAABBBBAAAABB\n"
"4: AAAABBBAAABBBAAABBBAAABBBAAAB\n"
"8: ABBBAAAABBAAAABBAAAABBAAAABBB\n"
"5: AAABBBBAAAABBBAAAABBBAAAABBAA\n"
"1: ABABABABABABABABABABABABABABABABABAB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")