// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^\d+:\s+
(
((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*A(AB)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*A(AB)*A)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*B(BA)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*B(BA)*B)
)$").unwrap();
let string = "4: AAAA
3: AAA
2: AA
1: A
4: BBBB
3: BBB
2: BB
1: B
2: AABBBBAAAABBBBAAAABBBB
3: AAABBBBAAABBBBAAAABBB
5: AAAAABBBBAAAABBBBAAAABB
3: AABBBAAAABBBBAAAABBBBAAA
4: AAABBBAAAABBBBAAAABBBBAA
1: ABABABABABABABABABABABABABABAB
8: AAAAAABBBBAAAAABBBBAAAAABBBB
2: AABBBBAAAABBBBAAAABBBBAAAAB
4: AAAABBBAAABBBAAABBBAAABBB
8: ABBBAAAABBAAAABBAAAABBAAAABB
5: AAABBBBAAAABBBAAAABBBAAAABB
1: ABABABABABABABABABABABABABABABAB
10: AAAAAABBBBAAAAAABBBBAAAAAABBBB
2: AABBBBAAAABBBBAAAABBBBAAAABB
4: AAAABBBAAABBBAAABBBAAABBBAA
8: ABBBAAAABBAAAABBAAAABBAAAAB
5: AAABBBBAAAABBBAAAABBBAAAAB
1: ABABABABABABABABABABABABABABAB
10: AAAAAABBBBAAAAAABBBBAAAAAABBB
2: AABBBBAAAABBBBAAAABBBBAAAABB
4: AAAABBBAAABBBAAABBBAAABBBAAA
8: ABBBAAAABBAAAABBAAAABBAAAABB
5: AAABBBBAAAABBBAAAABBBAAAABB
1: ABABABABABABABABABABABABABABABABAB
10: AAAAAABBBBAAAAAABBBBAAAAAABBBB
2: AABBBBAAAABBBBAAAABBBBAAAABB
4: AAAABBBAAABBBAAABBBAAABBBAAAB
8: ABBBAAAABBAAAABBAAAABBAAAABBB
5: AAABBBBAAAABBBAAAABBBAAAABBAA
1: ABABABABABABABABABABABABABABABABABAB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}