import Foundation
let pattern = #"""
^\d+:\s+
(
((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*A(AB)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*A(A(AB)*B)*A(AB)*A)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*B(BA)*)
|(((A(A(AB)*B)*B)|(B(B(BA)*A)*A))*B(B(BA)*A)*B(BA)*B)
)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
4: AAAA
3: AAA
2: AA
1: A
4: BBBB
3: BBB
2: BB
1: B
2: AABBBBAAAABBBBAAAABBBB
3: AAABBBBAAABBBBAAAABBB
5: AAAAABBBBAAAABBBBAAAABB
3: AABBBAAAABBBBAAAABBBBAAA
4: AAABBBAAAABBBBAAAABBBBAA
1: ABABABABABABABABABABABABABABAB
8: AAAAAABBBBAAAAABBBBAAAAABBBB
2: AABBBBAAAABBBBAAAABBBBAAAAB
4: AAAABBBAAABBBAAABBBAAABBB
8: ABBBAAAABBAAAABBAAAABBAAAABB
5: AAABBBBAAAABBBAAAABBBAAAABB
1: ABABABABABABABABABABABABABABABAB
10: AAAAAABBBBAAAAAABBBBAAAAAABBBB
2: AABBBBAAAABBBBAAAABBBBAAAABB
4: AAAABBBAAABBBAAABBBAAABBBAA
8: ABBBAAAABBAAAABBAAAABBAAAAB
5: AAABBBBAAAABBBAAAABBBAAAAB
1: ABABABABABABABABABABABABABABAB
10: AAAAAABBBBAAAAAABBBBAAAAAABBB
2: AABBBBAAAABBBBAAAABBBBAAAABB
4: AAAABBBAAABBBAAABBBAAABBBAAA
8: ABBBAAAABBAAAABBAAAABBAAAABB
5: AAABBBBAAAABBBAAAABBBAAAABB
1: ABABABABABABABABABABABABABABABABAB
10: AAAAAABBBBAAAAAABBBBAAAAAABBBB
2: AABBBBAAAABBBBAAAABBBBAAAABB
4: AAAABBBAAABBBAAABBBAAABBBAAAB
8: ABBBAAAABBAAAABBAAAABBAAAABBB
5: AAABBBBAAAABBBAAAABBBAAAABBAA
1: ABABABABABABABABABABABABABABABABABAB
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)