use strict;
my $str = ':[[[7.365046,46.948655],[7.365046,46.949254],[7.367558,46.949254],[7.367558,46.948655],[7.365046,46.948655]]]}}';
my $regex = qr/(?::\[\[)?\[([-+]?\d+\.\d+)\s*,\s*([-+]?\d+\.\d+)\]\s*,?(?:\]\]}})?/mp;
my $subst = '{\\n"@type": "point",\\n"lat":"$1",\\n"lon":"$2"\\n},\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";