$re = '/(?::\[\[)?\[([-+]?\d+\.\d+)\s*,\s*([-+]?\d+\.\d+)\]\s*,?(?:\]\]}})?/m';
$str = ':[[[7.365046,46.948655],[7.365046,46.949254],[7.367558,46.949254],[7.367558,46.948655],[7.365046,46.948655]]]}}';
$subst = "{\n\"@type\": \"point\",\n\"lat\":\"$1\",\n\"lon\":\"$2\"\n},\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;