import re
regex = re.compile(r"(?::\[\[)?\[([-+]?\d+\.\d+)\s*,\s*([-+]?\d+\.\d+)\]\s*,?(?:\]\]}})?", flags=re.MULTILINE)
test_str = ":[[[7.365046,46.948655],[7.365046,46.949254],[7.367558,46.949254],[7.367558,46.948655],[7.365046,46.948655]]]}}"
subst = "{\\n\"@type\": \"point\",\\n\"lat\":\"$1\",\\n\"lon\":\"$2\"\\n},\\n"
result = regex.sub(subst, test_str)
if result:
print(result)