const regex = /(?<!')^([^']+)'(\.?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\')^([^\']+)\'(\\.?)$', 'gm')
const str = `диагностировать болезнь и найти лечение'.`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);