use strict;
my $str = 'диагностировать болезнь и найти лечение\'.';
my $regex = qr/(?<!')^([^']+)'(\.?)$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";