re = /(?<!')^([^']+)'(\.?)$/m
str = 'диагностировать болезнь и найти лечение\'.'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result