package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Increases weather temp by up to (\d+))`)
var str = `Increases weather temp by up to 125`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}