re = /(Increases weather temp by up to (\d+))/m
str = 'Increases weather temp by up to 125'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end