$re = '`(Increases weather temp by up to (\d+))`m';
$str = 'Increases weather temp by up to 125';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);