using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.{1,250}$)(.+)@(.+){2,}\.(.+){2,}";
string input = @"sffffffffffffffffffffffffffffffffffffffffffffffffffffffs.s@sffffffffffffffffffffffffffffffffffffffffffffffffffdf.comfffffffffffffffffffffffffffffffffffffffffffffffff";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}