$re = '/(?=.{1,250}$)(.+)@(.+){2,}\.(.+){2,}/';
$str = 'sffffffffffffffffffffffffffffffffffffffffffffffffffffffs.s@sffffffffffffffffffffffffffffffffffffffffffffffffffdf.comfffffffffffffffffffffffffffffffffffffffffffffffff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);