re = /(?=.{1,250}$)(.+)@(.+){2,}\.(.+){2,}/
str = 'sffffffffffffffffffffffffffffffffffffffffffffffffffffffs.s@sffffffffffffffffffffffffffffffffffffffffffffffffffdf.comfffffffffffffffffffffffffffffffffffffffffffffffff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end