package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([A-Za-z]{3}\s[0-9]{1,2})\s?([0-9]{2}:[0-9]{2})?\s?-?\s?([0-9]{2}:[0-9]{2})?\s?([A-Z0-9]{3,4})?\s?)`)
var str = `Sun 16
08:00 -
16:00
RTW
Mon 17
08:00 - 16:00
RTW
Tue 18
08:00 -
16:00
RTW
Wed 19
08:00 -
16:00
RTW
Thu 20
08:00 - 16:00
RTW
Fri 21
08:00 - 16:00
RTW
Sat 22
OFF
Sun 23
OFF
Mon 24
OFF
Tue 25
04:40 -
13:07
5180
KM+
Wed
26
04:11
-
12:22
5178
Thu 27
10:00 - 18:00
Work.Group
Scheduling &
Rostering 1300-
1500 @Burwood...
Fri 28
OFF
Sat 29
NTA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}