# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([A-Za-z]{3}\s[0-9]{1,2})\s?([0-9]{2}:[0-9]{2})?\s?-?\s?([0-9]{2}:[0-9]{2})?\s?([A-Z0-9]{3,4})?\s?)"
test_str = ("Sun 16\n"
"08:00 -\n"
"16:00\n"
"RTW\n"
"Mon 17\n"
"08:00 - 16:00\n"
"RTW\n"
"Tue 18\n"
"08:00 -\n"
"16:00\n"
"RTW\n"
"Wed 19\n"
"08:00 -\n"
"16:00\n"
"RTW\n"
"Thu 20\n"
"08:00 - 16:00\n"
"RTW\n"
"Fri 21\n"
"08:00 - 16:00\n"
"RTW\n"
"Sat 22\n"
"OFF\n"
"Sun 23\n"
"OFF\n"
"Mon 24\n"
"OFF\n"
"Tue 25\n"
"04:40 -\n"
"13:07\n"
"5180\n"
"KM+\n"
"Wed\n"
"26\n"
"04:11\n"
"-\n"
"12:22\n"
"5178\n"
"Thu 27\n"
"10:00 - 18:00\n"
"Work.Group\n"
"Scheduling &\n"
"Rostering 1300-\n"
"1500 @Burwood...\n"
"Fri 28\n"
"OFF\n"
"Sat 29\n"
"NTA")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.