const regex = /(([A-Za-z]{3}\s[0-9]{1,2})\s?([0-9]{2}:[0-9]{2})?\s?-?\s?([0-9]{2}:[0-9]{2})?\s?([A-Z0-9]{3,4})?\s?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([A-Za-z]{3}\\s[0-9]{1,2})\\s?([0-9]{2}:[0-9]{2})?\\s?-?\\s?([0-9]{2}:[0-9]{2})?\\s?([A-Z0-9]{3,4})?\\s?)', 'gm')
const str = `Sun 16
08:00 -
16:00
RTW
Mon 17
08:00 - 16:00
RTW
Tue 18
08:00 -
16:00
RTW
Wed 19
08:00 -
16:00
RTW
Thu 20
08:00 - 16:00
RTW
Fri 21
08:00 - 16:00
RTW
Sat 22
OFF
Sun 23
OFF
Mon 24
OFF
Tue 25
04:40 -
13:07
5180
KM+
Wed
26
04:11
-
12:22
5178
Thu 27
10:00 - 18:00
Work.Group
Scheduling &
Rostering 1300-
1500 @Burwood...
Fri 28
OFF
Sat 29
NTA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}