#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<Date>[\d\/]+)\s*(?<Reason>\w+)\s*(?<ReferalFrom>\w+\s\w+)\s*(?<ReferalTo>\S+)\s*(?<Speciality>\w+\s\w+)\s*(?<StartDate>[\d\/]+)\s*(?<EndDate>[\d\/]+)\s(?<Allowed>\d+)"
Local $sString = "5/20/2022 PT AUTH PENDING Gupta,Saroj Sports Medici 05/20/2022 05/20/2023 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")